Back to overview
Downtime

Minecraft Server Outage

Feb 27 at 03:29pm UTC
Affected services
CreateSMP

Resolved
Feb 27 at 03:31pm UTC

The Issue was resolved.

Created
Feb 27 at 03:29pm UTC

We are currently experiencing issues with the server.